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This project introduces an Avian Ultrasonic Deterrent System designed for farms to effectively monitor and mitigate bird and 

pest activities. While birds and pests play a crucial role in fertilization, their presence can lead to significant crop damage and 

subsequent economic losses. Conventional deterrent systems have proven inadequate in addressing this issue. To overcome these 

limitations, we propose a novel solar-powered mobile system equipped with motion detection, ultrasonic technology for pest 

control, human-like motion simulation, and alarming sounds. Additionally, the system is integrated with sensors for monitoring 

soil moisture and temperature .Mounted on a study metal pole, the system operates autonomously, providing a modern and 

sustainable approach to agricultural pest management. By simulating human presence and employing various deterrent 

mechanisms, it effectively deters birds, animals, and pests, thus safeguarding crops and enhancing agricultural productivity. 

 

KEYWORDS: Solar-powered moving system, Pest control, Motion detection, Sustainable agricultural management. 

1. INTRODUCTION 

In modern agriculture, the presence of birds and pests 

poses significant challenges to farmers worldwide. 

While these creatures play vital roles in ecological 

balance, their unchecked presence can lead to substantial 

crop damage and economic losses. Conventional 

methods of pest control often prove ineffective or 

unsustainable, necessitating the development of 

innovative solutions that strike a balance between crop 

protection and environmental sustainability. 

Brief review of the Project: 

Avian Ultrasonic Deterrent Systems reveals a growing 

interest in utilizing ultrasonic technology for agricultural 

pest management. Research studies and pilot projects 

have explored the effectiveness of ultrasonic deterrent 

systems in deterring birds and pests from agricultural 

fields. 
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Key findings suggest that ultrasonic deterrent systems 

can be an effective, non-invasive, and environmentally 

friendly alternative to traditional methods of pest 

control. By emitting high-frequency sound waves that 

are outside the range of human hearing, these systems 

disrupt the behavior of birds and pests without causing 

harm to them or the environment. 

Furthermore, advancements in technology, such as 

motion detection and solar power integration, have 

enhanced the capabilities of ultrasonic deterrent 

systems, making them more versatile and sustainable. 

While promising, further research and field testing are 

needed to optimize the performance of Avian Ultrasonic 

Deterrent Systems and ensure their practical viability in 

real-world agricultural settings. Additionally, 

considerations such as system design, deployment 

strategies, and species-specific responses need to be 

taken into account to maximize effectiveness and 

minimize environmental impact. 

Project Objectives: 

The main objectives of the "Design and Fabrication of 

Avian Ultrasonic Deterrent System" project are as 

follows: 

 To design a robust and scalable avian deterrent 

system capable of effectively deterring birds and 

pests from agricultural fields. 

 To fabricate the proposed system using 

environmentally friendly materials and sustainable 

manufacturing processes. 

 To integrate advanced technologies, including 

ultrasonic technology, motion detection, and solar 

power, into the deterrent system to enhance its 

effectiveness and sustainability. 

 To evaluate the performance of the fabricated 

system through field trials and assessments, 

ensuring its practical viability and efficacy in 

real-world agricultural settings. 

 

 2. LITERATURE SURVEY 

1. R. Garcia and E. Martinez (2021): Optimization of 

avian ultrasonic deterrent systems through feedback 

mechanisms derived from environmental sensing 

data. It analyzes the role of sensing feedback in 

improving system performance and mitigating bird 

and pest activities in farm environments.  

2. Patel, R. Gupta (2018): Explored the application of 

ultrasonic technology in deterring birds from 

agricultural fields. The research demonstrated the 

effectiveness of ultrasonic deterrent systems in 

reducing bird damage to crops, highlighting their 

potential for agricultural pest management. 

3. Jones et al. (2016): Conducted field trials to evaluate 

the efficacy of ultrasonic deterrent systems in 

deterring pest birds from vineyards. The study 

concluded that ultrasonic frequencies effectively 

deterred birds without causing harm to crops or the 

environment. 

4. K. Smith et al. (2015): Investigated the effectiveness of 

ultrasonic deterrent systems in deterring birds from 

airport runways. The study found that ultrasonic 

frequencies disrupted bird behavior, reducing the 

risk of bird strikes on aircraft. 

5. Brown, S. Johnson (2017): Reviewed the current state 

of research on avian ultrasonic deterrent systems and 

identified areas for further investigation. The paper 

highlighted the need for interdisciplinary 

collaboration and field testing to optimize the 

effectiveness of ultrasonic technology in bird 

deterrence. 

    Process chart of Project: 

 
Design and Components Used: 

In the world of engineering and product design, 

computer-aided design (CAD) software plays a pivotal 

role in transforming ideas into tangible realities. Among 

the myriad of CAD tools available, NX CAD stands out 

as a powerful and comprehensive solution trusted by 

professionals across various industries. 

NX CAD, developed by Siemens Digital Industries 

Software, offers a robust suite of tools tailored for 

designing, simulating, and manufacturing complex 

products. It combines cutting-edge technology with 

intuitive interfaces, enabling engineers and designers to 

unleash their creativity while maintaining precision and 

efficiency. 
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     Drawing of our system in NX CAD 

 
Design of our system in NX CAD 

 

3. COMPONENTS USED 

Node MCU ESP8266: The ESP8266 module enables 

microcontrollers to connect to 2.4 GHz Wi-Fi, using IEEE 

802.11 bgn. It can be used with ESP-AT firmware to 

provide Wi-Fi connectivity to external host MCUs, or it 

can be used as a self-sufficient MCU by running an 

RTOS-based SDK. The module has a full TCP/IP stack 

and provides the ability for data processing, reads and 

controls of GPIOs. 

 

    

 

 

 L298N 2A Based Motor Driver Module: The L298N is a 

popular dual H-bridge motor driver IC that can control 

two DC motors or one stepper motor. The "2A" in its 

name refers to its maximum continuous output current 

per channel, which is around 2 amps. The L298N module 

typically includes the L298N IC along with additional 

components like diodes, capacitors, and connectors on a 

PCB, making it easier to use in motor control projects. It's 

widely used in robotics, automation, and other 

applications requiring motor control. 

 

 

Solar Panel: A 5W 6V solar panel with a junction box is a 

small photovoltaic module designed to generate 

electricity from sunlight.  

 
USB Solar Charge Controller Regulator 12V / 24V Auto 

Switch with LCD Display: A USB solar charge 
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controller regulator with a 12V/24V auto-switching 

feature and an LCD display is a device used to regulate 

the charging of batteries from solar panels 

 
Arduino UNO Sensor Shield Expansion Board V5: The 

Arduino UNO Sensor Shield Expansion Board V5 is an 

add-on board designed to simplify the process of 

connecting various sensors and modules to an Arduino 

UNO microcontroller board 

 
. Zero PCB General Purpose Board: The "Zero PCB 

General Purpose Board" likely refers to a prototyping 

board that has no specific layout or pattern, allowing 

users to design and create their own circuits from scratch 

 
24 Teeth Plastic Spur Gear with Metal Insert: The 

description "24 and 60 Teeth Plastic Spur Gears with 

Metal Insert (1.25M-60T-6-75)" provides detailed 

specifications for two plastic spur gears with metal 

inserts. 

 
5. SOFTWARE TOOLS AND INTERFACE 

STRATEGIES: The Arduino Integrated Development 

Environment - or Arduino Software (IDE) contains a text 

editor for writing code, a message area, a text console, a 

toolbar with buttons for common functions and a series 

of menus. It connects to the Arduino hardware to upload 

programs and communicate with them. 

 
SKETCHBOOK: 

The Arduino Software (IDE) uses the concept of a 

sketchbook: a standard place to store your programs (or 

sketches). The sketches in your sketchbook can be 

opened from the File > Sketchbook menu or from the 

Open button on the toolbar. The first time you run the 

Arduino software, it will automatically create a directory 

for your sketchbook. You can view or change the 

location of the sketchbook location from with the 

Preferences dialog. 

UPLOADING: Before uploading your sketch, you need 

to select the correct items from the Tools > Board and 

Tools > Port menus. The boards are described below. On 

Windows, it's probably COM1 or COM2 (for a serial 

board) or COM4, COM5, COM7, or higher (for a USB 

board) - to find out, you look for USB serial device in the 

ports section of the Windows Device Manager. Once 

you've selected the correct serial port and board, press 

the upload button in the toolbar or select the Upload 

item from the Sketch menu. Current Arduino boards will 

reset automatically and begin the upload. With older 

boards (pre- Diecimila) that lack auto-reset, you'll need 
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to press the reset button on the board just before starting 

the upload. On most boards, you'll see the RX and TX 

LEDs blink as the sketch is uploaded. The Arduino 

Software (IDE) will display a message when the upload 

is complete, or show an error 

6. Fabrication: 

 

 

 

 
 

4. CONCLUSION AND FUTURE SCOPE: 

"In this project, we propose a holistic solution to the 

persistent challenge of bird and pest damage in 

agricultural settings. By amalgamating cutting-edge 

technologies such as ultrasonic deterrents, motion 

detection, and environmental monitoring sensors, the 

system presents an inventive and eco-friendly approach 

to pest management on farms. Its capability to 

autonomously monitor and mitigate bird and pest 

activities while also furnishing valuable insights into soil 

conditions underscores its efficacy and potential impact 

on agricultural productivity. Through this endeavour, 

we have established the groundwork for a pragmatic 

and scalable solution that addresses the dual objectives 

of crop protection and environmental sustainability in 

agriculture. 

 

Future Scope: 

While the Avian Ultrasonic Deterrent System signifies a 

substantial advancement in agricultural pest 

management, there are numerous avenues for future 

research and development: 

Optimization and Refinement: Further fine-tuning of 

the system's design and functionality holds the promise 

of enhancing its efficacy in deterring a broader spectrum 

of bird and pest species while minimizing false alarms 

and energy consumption. 
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Field Testing and Validation: Carrying out extensive 

field trials across varied agricultural landscapes will 

yield invaluable insights into the system's performance 

under real-world conditions, facilitating adjustments 

based on feedback from farmers and stakeholders. 

Integration of AI and Machine Learning: Incorporating 

artificial intelligence and machine learning algorithms 

has the potential to enable the system to adapt and 

optimize its deterrent strategies through real-time data 

analysis and feedback, thus augmenting its efficacy over 

time. 

Expansion of Sensor Capabilities: Augmenting the 

system with additional sensors to monitor factors such 

as humidity, air quality, and crop health could further 

enrich its utility for farmers by furnishing 

comprehensive environmental monitoring and 

management capabilities. 

Scaling and Commercialization: Exploring avenues for 

scaling up production and commercializing the Avian 

Ultrasonic Deterrent System would facilitate broader 

adoption among farmers and agricultural communities, 

thereby maximizing its potential impact on crop 

protection and productivity." 
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